Deposits
Incident Report for RevenYOU
Resolved
This incident has been resolved.
Posted Oct 22, 2021 - 09:18 CEST
Update
We are continuing to investigate this issue.
Posted Oct 22, 2021 - 09:18 CEST
Investigating
Some users encounter issues with starting a bot. The bot could show a flat line, the deposit is taken to the bot and the bot will start within 48 hours.
Posted Oct 21, 2021 - 16:55 CEST
This incident affected: App IOS and App Android.