Server issue!
Incident Report for RevenYOU
Resolved
This incident has been resolved.
Posted Jan 08, 2021 - 21:06 CET
Update
We are continuing to investigate this issue.
Posted Jan 08, 2021 - 16:47 CET
Update
We are continuing to investigate this issue.
Posted Jan 08, 2021 - 15:42 CET
Investigating
It is possible to experience an unstable server. You may get an error message your telephone number is not linked to an account, we are working on it!
Posted Jan 08, 2021 - 14:42 CET
This incident affected: App IOS and App Android.