Withdrawal payment
Incident Report for RevenYOU
Resolved
This incident has been resolved.
Posted Jul 29, 2020 - 14:55 CEST
Investigating
Currently we are working on withdrawal requests. Users report they didn't receive the withdrawal amount.
Please subscribe to this issue, to stay informed.
Posted Jul 29, 2020 - 11:39 CEST
This incident affected: App IOS and App Android.