Availability in Google Play Store

Incident Report for RevenYOU

Resolved

This incident has been resolved.
Posted May 20, 2022 - 16:44 CEST

Identified

You may temporarily encounter issues with finding the BOTS App in Google Play Store. We are aware and in contact with Google to resolve the issue.
Posted May 19, 2022 - 11:59 CEST
This incident affected: App Android.